Sony Xperia TX - user opinions and reviews

Sony

Popularity

Daily interest
1.0%
Total hits:
2569685

Voting results

Design
7.4
Features
7.2
Performance
7.2
Votes:
408

Sort by:

> In reply to NikiDroid @ 2014-04-09 06:11 from tDMy - click to readThe new firmware is much better than the old one. And my phone is more stable.. And less hang or auto restart..

  • Reply
  • 2014-04-10 03:45
  • ibpM
  • R

> In reply to Sony Lover freaky @ 2014-04-09 16:11 from HjBG - click to readIn previous comments, several said use App2 SD app. You're lucky if you didn't experience shut down by itself when charging reach 100%.

  • Reply
  • 2014-04-09 16:59
  • 6}{G
  • R

Looks like you guys got a problem like your tx shutdown when reach 100% battery and whatsoever,btw i update mine with no problems at all,and before update it i have 64 downloaded apps and after update i didn't reset my phone and still my phone got no problem:-).....Wait!! Do you guys know how to move apps to memory stick??bcoz this phone has 2gb system memory,10gb internal sd card for music photo,apps,video,data but my question is how to move apps from internal sd card to my 32gb sd card stick???any ideas??

  • Reply
  • 2014-04-09 16:11
  • HjBG
  • U

> In reply to aopu98r @ 2014-03-11 21:12 from K2FN - click to readDo facrory reset. I experienced switch off by itself once when the battery reached 100% in charging and once the screen off by itself when I charged my device (battery left 7%), the LED was red, not orange, the phone still could operate like receive message, incoming call, email, WhatsApp, etc, but the screen didn't want to switch on, That was need to be pull out the battery to make it appear normal again. After I did factory reset, looks it better than before.

  • Reply
  • 2014-04-09 06:25
  • tDMy
  • R

> In reply to littleworm @ 2014-04-08 04:46 from uCpe - click to readI hope so for KitKat, in Sony website it still investigation.

  • Reply
  • 2014-04-09 06:16
  • tDMy
  • R

> In reply to littleworm @ 2014-04-08 04:46 from uCpe - click to readMaybe it was your country Sony server. Before I updated to 9.A.1.205, my Xperia showed 9.A.1.199 (8,4 MB), I updated using WiFi modem, tried more than 3 times, couldn't install. So I use office PC to update it via Sony PC Conpanion, it detected 'new update available' I saw it named 9.A.1.205, I clicked update and wait, after finish I switch on my device, nothing different, only OS version and it has preloaded Google Drive.

  • Reply
  • 2014-04-09 06:11
  • tDMy
  • R

> In reply to NikiDroid @ 2014-04-06 20:46 from tDMy - click to readI have just use the Sony PC Companion to update the firmware from 9.2.A.1.199 to 9.2.A.1.205.. But from the Sony Official site is not show and with this latest firmware and don't know what is the new improvements for it and with the bug fix.. Hope the KitKat is coming soon for this model..

  • Reply
  • 2014-04-08 04:46
  • uCpe
  • R

> In reply to Sony Lover freaky @ 2014-04-07 16:17 from RIE@ - click to readNice, one of Xperia TX users have experienced better in latest Jelly Bean 4.3. Nice to read your post.

  • Reply
  • 2014-04-08 04:08
  • 6}%j
  • R

Just update mine to 9.2.A.1.205 and it's awesome.No more bugs on volume bar when you use theme from play store.but still i will wait for kitkat to this phone...Happy update.

  • Reply
  • 2014-04-07 16:17
  • RIE@
  • U

> In reply to tx user @ 2014-03-06 22:46 from y@W5 - click to readYes I experienced that once, second and next.I didn't experience yet again.

  • Reply
  • 2014-04-06 20:53
  • tDMy
  • R

> In reply to littleworm @ 2014-03-16 18:45 from PTGp - click to readLatest update in Jelly Bean 4.3 that I noticed and tried was 9.2.A.1.205. I used PC update it.

  • Reply
  • 2014-04-06 20:46
  • tDMy
  • R

The ePSXe has been fixed ny itself after I moved one of my ISO roms. So far in Jelly Bean 4.3 Xperia TX works very good better than ICS 4.0.4.

  • Reply
  • 2014-04-06 15:23
  • tDMy
  • U

I had updated to latest version, 9.2.A.1.205 (Jelly Bean 4.3). This latest version should be used Sony PC Companion. Overall in Jelly Bean 4.3 I don't experience lag or hang, it works smootha, typing faster than ICS. The problem is ePSXe doesn't detect PSX rom isos that I put in microSD.

  • Reply
  • 2014-04-04 13:23
  • tDMx
  • U

I had updated to Jelly Bean 4.3 (9.2.A.0.9.25) on my Xperia TX. What I can say, it is awesome, performance is fast. The RAM usage is better than before (now total RAM is 848 MB, previously in ICS 4.0.4 only around 600 MB). After I had updated the IS version, now it shows next 8,3 MB update (9.2.A.1.199).

  • Reply
  • 2014-04-03 22:18
  • PxVj
  • U

> In reply to Daniyal @ 2014-03-08 23:20 from 6QHh - click to readI am new in using Xperia TX. Well, this smartphone ia very good in design, features are goos, thick and compact to handle. The advantages I notice are can't do native video call via operator, the memory system is divided to 2 parts. This is not good idea I think. First part named downloaded that has 1,97 GB in total, second part named internal storage 10 GB. The advantage is downloaded part. All downloaded apps will be saved in that section, yes several apps can be moved to internal memory but like BBM, WhatsApp, YM, can't be mobed to internal storage.This like Galaxy Ace 2 I8160 that has downloaded section and USB storage section. Say if Sony doesn't create downloaded section that has 1,97 GB only, I think it would be better, all downloaded apps will be saved in internal storage.

  • Reply
  • 2014-04-01 20:59
  • 6}EC
  • R

> In reply to jospi @ 2014-04-01 12:46 from K6mH - click to readAre there down performance in opening apps, swipe left or swipe right in menu display, in typing /(messaging, commenting in website, Tweet, Facebook), lag or hang in Jelly Bean 4.3 you had updated?

  • Reply
  • 2014-04-01 18:07
  • 6}EC
  • R

> In reply to xperia TX user @ 2014-03-10 09:15 from P5J6 - click to readsame to u pblm +iphn headphn nt working

  • Reply
  • 2014-04-01 13:03
  • K6mH
  • R

hi im jospi frm oman.sony xperia tx is my fvrt phone. 6 month going i use this phn. i use iphne 5 headphne its working & exilent sound qualty. bt yestarday i update in jellybeen 4.3 well bt when i ply video its a flasing blue colore & shocking news is a iphone headphone are nt working!!! also whn i use sony headphne thn display nt showing headphne logo bt its working...

  • Reply
  • 2014-04-01 12:46
  • K6mH
  • U

> In reply to Mousum @ 2014-04-01 10:12 from P@PD - click to readSounds not good, cause reset will give consequence of download back the apps that users installed. If the condition he/she in free public WiFi area is OK, but if not, it will waste his/her internet quota.

  • Reply
  • 2014-04-01 12:06
  • 6}Lg
  • R
Sort by:
Total of 2195 user reviews and opinions for Sony Xperia TX.