<!doctype html>
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-US" lang="en-US">
<head>
<title>Samsung Galaxy M31s hands-on review - GSMArena.com tests</title>
<script>
DESKTOP_BASE_URL = "https://www.gsmarena.com/";
ASSETS_BASE_URL  = "https://fdn.gsmarena.com/vv/assets12/";
CDN_BASE_URL = "//fdn.gsmarena.com/";
CDN2_BASE_URL = "//fdn2.gsmarena.com/";
</script>

<script data-cfasync="false" type="text/javascript">(function(w, d) { var s = d.createElement('script'); s.src = '//delivery.adrecover.com/16425/adRecover.js?ts=1527752433225'; s.type = 'text/javascript'; s.async = true; (d.getElementsByTagName('head')[0] || d.getElementsByTagName('body')[0]).appendChild(s); })(window, document);</script>

<meta charset="utf-8">
<meta name="viewport" content="width=1060, initial-scale=1.0">
<link rel="stylesheet" href="https://fdn.gsmarena.com/vv/assets12/css/gsmarena.css?v=14">

<link rel="shortcut icon" href="https://fdn.gsmarena.com/imgroot/static/favicon.ico">

<!-- OneTrust Cookies Consent Notice start -->
<script type="text/javascript" src="https://cdn.cookielaw.org/consent/ee7f4a73-10bf-4a4b-9778-5d471df55f5d/OtAutoBlock.js"></script>
<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js"  type="text/javascript" charset="UTF-8" data-domain-script="ee7f4a73-10bf-4a4b-9778-5d471df55f5d"></script>
<script type="text/javascript">
function OptanonWrapper() { }
</script>
<!-- OneTrust Cookies Consent Notice end -->








<script type="text/javascript" src="//dsh7ky7308k4b.cloudfront.net/publishers/gsmarenacom.min.js"></script>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
	
	googletag.defineSlot('/8095840/.2_A.34912.3_gsmarena.com_tier1', [728, 90], 'div-gpt-ad-top728x90gsmarenadesktop-0').setTargeting('pageid', '71').addService(googletag.pubads());
	
	googletag.defineSlot('/8095840/.2_A.35452.4_gsmarena.com_tier1', [300, 250], 'div-gpt-ad-gsmarenacom35452').setTargeting('pageid', '71').addService(googletag.pubads());
	
	googletag.defineSlot('/8095840/.2_A.34911.7_gsmarena.com_tier1', [[300, 250], [300, 600]], 'div-gpt-ad-300x600btfgsmarenadesktop-0').setTargeting('pageid', '71').addService(googletag.pubads());
	
	googletag.defineSlot('/8095840/.2_A.35282.4_gsmarena.com_tier1', [300, 250], 'div-gpt-ad-300x250mid-left-mpugsmarenadesktop-0').setTargeting('pageid', '71').addService(googletag.pubads());



	googletag.enableServices();
  });
</script>


<link rel="stylesheet" href="https://fdn.gsmarena.com/vv/assets12/css/reviews.css?v=4">
<link rel="stylesheet" href="https://fdn.gsmarena.com/vv/assets12/css/comments-2.css?v=1">




<meta name="Description" content="The Galaxy M31s is the latest in Samsung&#039;s line of all too similar phones. It is the upgraded version of the Galaxy M31, which is similar to the M21 and...">

<meta property="og:title" content="Samsung Galaxy M31s hands-on review"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="https://www.gsmarena.com/samsung_galaxy_m31s-review-2163.php"/>
<meta property="og:image" content="https://fdn.gsmarena.com/imgroot/reviews/20/samsung-galaxy-m31s/thumb/-728x314/gsmarena_001.jpg"/>
<meta property="og:site_name" content="GSMArena.com"/>
<meta property="og:description" content="The Galaxy M31s is the latest in Samsung&#039;s line of all too similar phones. It is the upgraded version of the Galaxy M31, which is similar to the M21 and..."/>

<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@gsmarena_com">
<meta name="twitter:url" content="https://www.gsmarena.com/samsung_galaxy_m31s-review-2163.php">
<meta name="twitter:title" content="Samsung Galaxy M31s hands-on review">
<meta name="twitter:description" content="The Galaxy M31s is the latest in Samsung&#039;s line of all too similar phones. It is the upgraded version of the Galaxy M31, which is similar to the M21 and...">
<meta name="twitter:image" content="https://fdn.gsmarena.com/imgroot/reviews/20/samsung-galaxy-m31s/thumb/-728x314/gsmarena_001.jpg">

<link rel="canonical" href="https://www.gsmarena.com/samsung_galaxy_m31s-review-2163.php">
<link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.gsmarena.com/samsung_galaxy_m31s-review-2163.php">

<link rel="next" href="https://www.gsmarena.com/samsung_galaxy_m31s-review-2163p2.php">

<script type="application/ld+json">
{
    "@context": "https://schema.org/",
    "@type": "Review",
        "itemReviewed": {
			"@type": "Product",
			"name": "Samsung Galaxy M31s",
			"review": {
          		"@type": "Review",
          		"author": {
          		  "@type": "Person",
          		  "name": "GSMArena team"
          		},
        
          		"inLanguage": "en"	
          	},
			"image": {
			    "@type": "ImageObject",
			    "url": "https://fdn.gsmarena.com/imgroot/reviews/20/samsung-galaxy-m31s/thumb/-728x314/gsmarena_001.jpg",
			    "height":"314",
			    "width": "728"
			}
    	},
		"name": "Samsung Galaxy M31s hands-on review",
		"author": {
		  "@type": "Person",
		  "name": "GSMArena team"
		},
		"datePublished": "09 Sep 2020"
}</script>

<script language="JavaScript">
<!--
function BigImg(ARI,IMI)
{
  return false;
}

function ShowFullThumbNail(id_file, width, height, title){
window.open("http://www.mobilmania.cz/ShowFullThumbNail.aspx?id_file=" + id_file + "&width=" + width + "&height=" + height + "&title=" + title,"fullImage" + id_file, "scrollbars=no,status=yes,location=yes,width=" + width + ",height=" + height);
return false;
}

function ShowArticleImage(id_file, width, height, title, id_article){
return ShowFullThumbNail(id_file, width, height, title)
}

function ShowCatalogThumbNail(fname, ftitle){
var rnd = Math.floor(1000000*Math.random());
window.open("http://www.mobilmania.cz/ShowFullThumbNail.aspx?file=" + fname + "&title=" + ftitle, "fullImage" + rnd, "scrollbars=no, status=yes");
return false;
}

function ShowImg(sImg)
{
	ImagePopup( "https://fdn.gsmarena.com/vv/", sImg );
}

function ShowImg2(sImg)
{
	ImagePopup( "https://fdn.gsmarena.com/imgroot/", sImg );
}

function PopUp(sURL)
{
	window.open(sURL,'','status=1,scrollbars=1,width=730,height=720,resizable=1')
}
function PopUp2(sURL)
{
	window.open(sURL,'','status=1,scrollbars=1,width=830,height=750,resizable=1')
}

//-->
</script> 


</head>
<body>



<script type="text/javascript" src="https://fdn.gsmarena.com/vv/assets12/js/misc.js"></script>

<script language='JavaScript' type='text/javascript'>
function phpads_deliverActiveX(content)
{
	document.write(content);	
}
</script>
<header id="header" class="row">
<div class="wrapper clearfix">
<div class="top-bar clearfix">
<!-- HAMBURGER MENU -->
<button type="button" role="button" aria-label="Toggle Navigation" class="lines-button minus focused">
<span class="lines"></span>
</button>
<!-- /HAMBURGER MENU -->



<!-- LOGO -->
<div id="logo">
<a href="/">

<object type="image/svg+xml" data="https://fdn.gsmarena.com/vv/assets12/i/logo.svg"><img src="https://fdn.gsmarena.com/vv/assets12/i/logo-fallback.gif" alt="GSMArena.com"></object>
<span>GSMArena.com</span></a>
</div>



<div id="nav" role="main">
<form action="res.php3" method="get" id="topsearch">
    <input type="text" placeholder="Search" tabindex="201" accesskey="s" id="topsearch-text" name="sSearch" autocomplete="off" />
    <span id="quick-search-button">
      <input type="submit" value="Go" />
      <i class="head-icon icomoon-liga icon-search-left"></i>
    </span>
    

</form>
</div>


<div id="social-connect">
<a href="tipus.php3" class="tip-icon">
  <i class="head-icon icon-tip-us icomoon-liga"></i><br><span class="icon-count">Tip us</span>
</a>
<a href="https://www.facebook.com/GSMArenacom-189627474421/" class="fb-icon" target="_blank" rel="noopener">
  <i class="head-icon icon-soc-fb2 icomoon-liga"></i><br><span class="icon-count">887k</span>
</a>
<a href="https://twitter.com/gsmarena_com" class="tw-icon" target="_blank" rel="noopener">
  <i class="head-icon icon-soc-twitter2 icomoon-liga"></i><br><span class="icon-count">153k</span>
</a>

<a href="https://www.instagram.com/gsmarenateam/" class="ig-icon" target="_blank" rel="noopener">
  <i class="head-icon icon-instagram icomoon-liga"></i>
  <span class="icon-count">62k</span>
</a>
<a href="https://www.youtube.com/channel/UCbLq9tsbo8peV22VxbDAfXA?sub_confirmation=1" class="yt-icon" target="_blank" rel="noopener">
  <i class="head-icon icon-soc-youtube icomoon-liga"></i><br><span class="icon-count">1m</span>
</a>
<a href="rss-news-reviews.php3" class="rss-icon">
  <i class="head-icon icon-soc-rss2 icomoon-liga"></i><br><span class="icon-count">RSS</span>
</a>




	<a href="#" onclick="return false;" class="login-icon" id="login-active">
	  <i class="head-icon icon-login"></i><br><span class="icon-count" style="right:4px;">Log in</span>
	</a>

	<span class="tooltip" id="login-popup2">
<form action="login.php3" method="post">
<input type="Hidden" name="sSource" value="MGx%2BcmxqcXhAeH5zfmdmQHIsLmwybXppdnpoMi0uKSwxb3dv">  
	<p>Login</p>
	<label for="email"></label>
	<input type="email" id="email" name="sEmail" maxlength="50" value="" required="" autocomplete="false">

	<label for="upass"></label>
	<input type="password" id="upass" name="sPassword" placeholder="Your password" maxlength="20" pattern="\S{6,}" required="" autocomplete="false">

	<input class="button" type="submit" value="Log in" id="nick-submit">
</form>
	<a class="forgot" href="forgot.php3">I forgot my password</a>
	</span>
 <a href="register.php3" class="signup-icon no-margin-right"><i class="head-icon icon-user-plus"></i><span class="icon-count">Sign up</span></a>  
              </div>  
           </div>                 
<ul id="menu" class="main-menu-list">
	<li><a href="/">Home</a></li>
	<li><a href="news.php3">News</a></li>
	<li><a href="reviews.php3">Reviews</a></li>
  <li><a href="videos.php3">Videos</a></li>
	<li><a href="news.php3?sTag=Featured">Featured</a></li>
	<li><a href="search.php3">Phone Finder</a></li>
	<li><a href="tools.php3">Tools</a></li>
	<li><a href="glossary.php3">Glossary</a></li>
	<li><a href="network-bands.php3">Coverage</a></li>
	<li><a href="contact.php3">Contact</a></li>                   
</ul>
  


      <!-- SOCIAL CONNECT -->
    </div>
    

</header> <!--- HEADER END -->


		

<div id="wrapper" class="l-container">
<div id="outer" class="row">


<div id="subHeader" class="col">
<div id="topPromo">		
		<div class="alt-display is-review" style="background-image: url(https://fdn.gsmarena.com/imgroot/reviews/20/apple-iphone-se-2020/-347x151/thumb.jpg)">
		  <a class="table-cell reviews-xl-snazzy" href="apple_iphone_se_2020-review-2108.php">
			  <div class="module-review-xl-title">
				    	
			    	<strong>Apple iPhone SE (2020) review</strong>
			   
			  
		 	  </div>
		 </a>
	  </div>
</div><div id="topAdv" class="l-box" adonis-marker data-pan-sizes="[[728,90]]"><!-- /8095840/.2_A.34912.3_gsmarena.com_tier1 -->
<div id='div-gpt-ad-top728x90gsmarenadesktop-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-top728x90gsmarenadesktop-0'); });
</script>
</div>
	</div>   
</div>


<div id="body" class="clearfix">

<div class="main main-review l-box col float-right">  
<style type="text/css">
  .review-background {
    background-image: url('https://fdn.gsmarena.com/imgroot/reviews/20/samsung-galaxy-m31s/thumb/-728x314/gsmarena_001.jpg');
    background-size: 728px 314px;
  }  
</style>
<div class="review-header">  
  <div class="review-hd review-background">
    <div class="article-info">

<div class="article-info-line border-bottom">
<div class="blur review-background"></div>




<script>
	var sURLSocialE = "https%3A%2F%2Fwww.gsmarena.com%2Fsamsung_galaxy_m31s-review-2163.php";
</script>


<ul class="social-share sharrre close">
<li class="help help-social">
  <a class="box btnFb" title="Facebook" id="facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.gsmarena.com%2Fsamsung_galaxy_m31s-review-2163.php" target="_blank" rel="noopener" onclick="window.open('http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.gsmarena.com%2Fsamsung_galaxy_m31s-review-2163.php','fbookshare','width=500,height=400,left='+(screen.availWidth/2-225)+',top='+(screen.availHeight/2-150)+'');return false;">
    
    <div class="share">
      <i class="head-icon icon-soc-fb2"></i>
    </div>
  </a>
</li>
<li>
  <a class="box btnTw" title="Twitter" id="twitter" href="https://twitter.com/intent/tweet?text=Samsung+Galaxy+M31s+hands-on+review&url=https%3A%2F%2Fwww.gsmarena.com%2Fsamsung_galaxy_m31s-review-2163.php" target="_blank" rel="noopener" onclick="window.open('https://twitter.com/intent/tweet?text=Samsung+Galaxy+M31s+hands-on+review&url=https%3A%2F%2Fwww.gsmarena.com%2Fsamsung_galaxy_m31s-review-2163.php','twitshare','width=500,height=400,left='+(screen.availWidth/2-225)+',top='+(screen.availHeight/2-150)+'');return false;">
    <div class="share">
      <i class="head-icon icon-soc-twitter2"></i></div>
  </a>
</li>
<li>
    <a href="#"><div class="share share-button"><i class="head-icon icon-share"></i></div></a>
</li>
</ul>  

 <div class="meta-line meta-author ">
    <span class="reviewer">GSMArena team</span>,
    <span class="dtreviewed">09 Sep 2020</span>
    
</div>
</div>




        
<div class="center-stage article-accent">
<div class="article-hgroup">

    <h1 class="article-info-name">Samsung Galaxy M31s hands-on review</h1>
</div>

</div>


<div class="article-info-line">
<div class="blur bottom review-background"></div>
<ul class="article-info-meta">



<li class="article-info-meta-link meta-link-opinions"><a href="reviewcomm-2163.php"><i class="head-icon icon-comment-count"></i>Comments (51)</a></li> 
<li class="article-info-meta-link meta-link-ureviews"><a href="samsung_galaxy_m31s-reviews-10333.php"><i class="head-icon icon-user-reviews"></i>User reviews</a></li>
<li class="article-info-meta-link meta-link-specs"><a href="samsung_galaxy_m31s-10333.php"><i class="head-icon icon-mobile2"></i>Galaxy M31s</a></li>




<br style="clear:both;" />
</ul>
</div>
</div>


</div> 			
</div>



<div class="review-nav col row">
<div class="review-pages col col-4-5">
<div class="page-selected row no-push">
  <a title="1. Introduction"><strong>1. Introduction</strong></a>
</div>
<ol class="page-options col row no-push">

<li><a href="#"><strong>1. Introduction</strong></a></li><li><a href="samsung_galaxy_m31s-review-2163p2.php">2. Design, Display</a></li><li><a href="samsung_galaxy_m31s-review-2163p3.php">3. Software, Performance</a></li><li><a href="samsung_galaxy_m31s-review-2163p4.php">4. Camera</a></li><li><a href="samsung_galaxy_m31s-review-2163p5.php">5. Conclusion</a></li><li><a href="">&nbsp;</a></li> <li><a href="samsung_galaxy_m31s-10333.php">Samsung Galaxy M31s specification</a></li><li><a href="samsung_galaxy_m31s-reviews-10333.php">User opinions and reviews</a></li><li><a href="reviewcomm-2163.php">Review comments (51)</a></li>                 

</ol>
</div>
<div class="col col-1-5 pages-next-prev float-right">
<a class="disabled pages-prev" href="#" title="Previous page"></a><a class="pages-next" href="samsung_galaxy_m31s-review-2163p2.php" title="Next page"></a></div>
</div>
<div class="article-tags clearfix">
<p class="float-right">   
 <a href="reviews.php3?sTag=Samsung"><b>Samsung</b></a> <a href="reviews.php3?sTag=Android"><b>Android</b></a></p>
</div>
<div id="review-body" class="review-body clearfix">



  




<h3>Introduction</h3>


<p>The Galaxy M31s is the latest in Samsung's line of all too similar phones. It is the upgraded version of the Galaxy M31, which is similar to the M21 and is an upgraded version of the M30s. All of these phones look very similar, have nearly identical specifications with a few bits swapped around, and have all been released in the span of a year.</p>

<img class="inline-image" src="https://fdn.gsmarena.com/imgroot/reviews/20/samsung-galaxy-m31s/lifestyle/-727w2/gsmarena_001.jpg" height="485" width="727" alt="Samsung Galaxy M31s hands-on review">

<p>So what's the situation with the Galaxy M31s? Well, it seems despite the overwhelming similarity on paper, the Galaxy M31s seems to have a different body this time around, even though it oddly doesn't look all that different at first glance. Yet, there are enough changes here that need to go through a fine-toothed comb. These changes do subtly change the way you use the phone, so they aren't insignificant.</p>

<p>But as mentioned before, the Galaxy M31s is very similar to the other two phones, especially the M30s, in terms of hardware specifications. The display, the chipset, the memory and storage configuration, most of the cameras, and the battery are all identical across these models. This means if you already own a Galaxy M30s, then you really aren't missing out on much with the Galaxy M31s.</p>

<h3 class="article-blurb-title blurb-title-findings">Samsung Galaxy M31s specs</h3>
<ul class="article-blurb article-blurb-findings">
  <li><b>Body:</b> Glass front, polycarbonate back and side frame</li>
  <li><b>Screen:</b> 6.5-inch, 19.5:9, FHD+ (1080 x 2400px), Super AMOLED</li>
  <li><b>Rear camera:</b> Primary 64MP, f/1.8 aperture; Ultra wide-angle: 12MP, f/2.2 aperture; 5MP f2.4 Macro camera; 5MP depth sensor; LED flash; 2160p@30fps video recording</li>
  <li><b>Front camera:</b> 32MP, f/2.2 aperture</li>
  <li><b>Chipset:</b> Exynos 9611: octa-core CPU (4x2.3 GHz Cortex-A73 & 4x1.7 GHz Cortex-A53), Mali-G72 MP3 GPU</li>
  <li><b>Memory:</b> 6/128GB or 8/128GB UFS 2.1; dedicated microSD slot</li>
  <li><b>OS:</b> Android 10; Samsung One UI 2.1</li>
  <li><b>Battery:</b> 6,000mAh, 25W charging</li>
  <li><b>Connectivity:</b> Dual SIM (4G), Bluetooth 5.0, Wi-Fi a/b/g/n/ac, USB-C; 3.5mm audio jack</li>
  <li><b>Misc:</b> Side-mounted fingerprint reader, FM radio</li>

</ul>

<p>But for those who don't own any of these phones, the Galaxy M31s could be an attractive proposition. We have a large, relatively high-resolution AMOLED panel, lots of cameras of varying focal lengths, and an absolute behemoth of a battery. Sure, it lacks some of the niceties such as a higher resolution display or a more modern Snapdragon chipset, but the Galaxy M31s is cheaper than phones like the OnePlus Nord and the Google Pixel 4a.</p>

<p>So with all that in mind, should you be spending your hard-earned cash on the Samsung Galaxy M31s? Let's find out.</p>



</div>

<div class="article-pages col">
  <a href="samsung_galaxy_m31s-review-2163p2.php"><strong class="next-page">Next Page &raquo;</strong>
  <span>2. Design, Display</span></a>
  <a href="samsung_galaxy_m31s-review-2163p2.php" class="faux-link"></a>
</div>

<div class="review-nav col row">
<div class="review-pages col col-4-5">
<div class="page-selected row no-push">
  <a title="1. Introduction"><strong>1. Introduction</strong></a>
</div>
<ol class="page-options col row no-push">

<li><a href="#"><strong>1. Introduction</strong></a></li><li><a href="samsung_galaxy_m31s-review-2163p2.php">2. Design, Display</a></li><li><a href="samsung_galaxy_m31s-review-2163p3.php">3. Software, Performance</a></li><li><a href="samsung_galaxy_m31s-review-2163p4.php">4. Camera</a></li><li><a href="samsung_galaxy_m31s-review-2163p5.php">5. Conclusion</a></li><li><a href="">&nbsp;</a></li> <li><a href="samsung_galaxy_m31s-10333.php">Samsung Galaxy M31s specification</a></li><li><a href="samsung_galaxy_m31s-reviews-10333.php">User opinions and reviews</a></li><li><a href="reviewcomm-2163.php">Review comments (51)</a></li>                 

</ol>
</div>
<div class="col col-1-5 pages-next-prev float-right">
<a class="disabled pages-prev" href="#" title="Previous page"></a><a class="pages-next" href="samsung_galaxy_m31s-review-2163p2.php" title="Next page"></a></div>
</div>
<br class="clear">

<div class="breadcrumbs">
    <a class="crumb" href="reviews.php3">Reviews</a>
    <i class="head-icon arrow"></i>
<span class="crumb">Samsung Galaxy M31s hands-on review</span>      
</div>

<div class="article-info-line article-info-line-standalone page-specs light pushT10">

<ul class="article-info-meta">



<li class="article-info-meta-link meta-link-opinions"><a href="reviewcomm-2163.php"><i class="head-icon icon-comments"></i>Comments (51)</a></li> 
<li class="article-info-meta-link meta-link-ureviews"><a href="samsung_galaxy_m31s-reviews-10333.php"><i class="head-icon icon-user-reviews"></i>User reviews</a></li>
<li class="article-info-meta-link meta-link-specs"><a href="samsung_galaxy_m31s-10333.php"><i class="head-icon icon-mobile2"></i>Galaxy M31s</a></li>
<br style="clear:both;" />
</ul>
</div>


          
<div id="user-comments" class="box s3 nobg">
<h2><a href="reviewcomm-2163.php">Samsung Galaxy M31s hands-on review - Reader comments</a></h2> 
 
<div class="user-thread">
<div class="uavatar"><span class="avatar-box" style="background-color: #549fc8">A</span></div>

<ul class="uinfo2"><li class="uname2">Alop</li>
<li class="ulocation">
<i class="head-icon icon-location"></i>
<span title="Encoded anonymized location">tZj</span></li>
<li class="upost"><time class="" data-time="2014-06-14 07:31">6 hours ago</time></li>

</ul>

<p class="uopin">Cameras have improved. The water colour effect has been reduced significantly.</p>

<ul class="uinfo">
<li class="ureply">
<span title="Reply to this post">
<a href="postreviewcomment.php3?idReview=2163&idComment=298658">Reply</a></span>
</li>



</ul>


</div>
 
<div class="user-thread">
<div class="uavatar"><span class="avatar-box" style="background-color: #549fc8">?</span></div>

<ul class="uinfo2"><li class="uname2">Anonymous</li>
<li class="ulocation">
<i class="head-icon icon-location"></i>
<span title="Encoded anonymized location">wc6</span></li>
<li class="upost"><time class="" data-time="2014-06-14 07:31">10 hours ago</time></li>

</ul>

<p class="uopin">M series still have connection problem?</p>

<ul class="uinfo">
<li class="ureply">
<span title="Reply to this post">
<a href="postreviewcomment.php3?idReview=2163&idComment=298648">Reply</a></span>
</li>



</ul>


</div>
 
<div class="user-thread">
<div class="uavatar"><span class="avatar-box" style="background-color: #839a7e">?</span></div>

<ul class="uinfo2"><li class="uname2">Anonymous</li>
<li class="ulocation">
<i class="head-icon icon-location"></i>
<span title="Encoded anonymized location">mcB</span></li>
<li class="upost"><time class="" data-time="2014-06-14 07:31">15 hours ago</time></li>

</ul>

<p class="uopin">I &#039;ve already bought poco x3</p>

<ul class="uinfo">
<li class="ureply">
<span title="Reply to this post">
<a href="postreviewcomment.php3?idReview=2163&idComment=298629">Reply</a></span>
</li>



</ul>


</div>
 

<div class="sub-footer">
<div class="button-links">
<ul>
            
<li><a class="button" href="reviewcomm-2163.php">Read all comments</a></li>

<li><a class="button" href="postreviewcomment.php3?idReview=2163">Post your comment</a></li>
</ul>

</div>
<div id="opinions-total">Total reader comments: <b>51</b></div>
<br class="clear" />
             
            </div>
</div>            



</div>

<aside class="sidebar col left">

<div class="brandmenu-v2 light l-box clearfix">
<p class="pad">
<a href="search.php3" class="pad-single pad-finder">
<i class="head-icon icon-search-right"></i>
<span>Phone finder</span></a>
</p>
<ul>
<li><a href="samsung-phones-9.php">Samsung</a></li><li><a href="apple-phones-48.php">Apple</a></li><li><a href="huawei-phones-58.php">Huawei</a></li><li><a href="nokia-phones-1.php">Nokia</a></li><li><a href="sony-phones-7.php">Sony</a></li><li><a href="lg-phones-20.php">LG</a></li><li><a href="htc-phones-45.php">HTC</a></li><li><a href="motorola-phones-4.php">Motorola</a></li><li><a href="lenovo-phones-73.php">Lenovo</a></li><li><a href="xiaomi-phones-80.php">Xiaomi</a></li><li><a href="google-phones-107.php">Google</a></li><li><a href="honor-phones-121.php">Honor</a></li><li><a href="oppo-phones-82.php">Oppo</a></li><li><a href="realme-phones-118.php">Realme</a></li><li><a href="oneplus-phones-95.php">OnePlus</a></li><li><a href="vivo-phones-98.php">vivo</a></li><li><a href="meizu-phones-74.php">Meizu</a></li><li><a href="blackberry-phones-36.php">BlackBerry</a></li><li><a href="asus-phones-46.php">Asus</a></li><li><a href="alcatel-phones-5.php">Alcatel</a></li><li><a href="zte-phones-62.php">ZTE</a></li><li><a href="microsoft-phones-64.php">Microsoft</a></li><li><a href="vodafone-phones-53.php">Vodafone</a></li><li><a href="energizer-phones-106.php">Energizer</a></li><li><a href="cat-phones-89.php">Cat</a></li><li><a href="sharp-phones-23.php">Sharp</a></li><li><a href="micromax-phones-66.php">Micromax</a></li><li><a href="infinix-phones-119.php">Infinix</a></li><li><a href="ulefone_-phones-124.php">Ulefone</a></li><li><a href="tecno-phones-120.php">Tecno</a></li><li><a href="blu-phones-67.php">BLU</a></li><li><a href="acer-phones-59.php">Acer</a></li><li><a href="wiko-phones-96.php">Wiko</a></li><li><a href="panasonic-phones-6.php">Panasonic</a></li><li><a href="verykool-phones-70.php">verykool</a></li><li><a href="plum-phones-72.php">Plum</a></li></ul>

<p class="pad">
<a href="makers.php3" class="pad-multiple pad-allbrands">
  <i class="head-icon icon-mobile-phone231"></i>
  <span>All brands</span>
</a>
<a href="rumored.php3" class="pad-multiple pad-rumormill">
  <i class="head-icon icon-rumored"></i>
  <span>Rumor mill</span>
</a>
</p>
</div>
<div class="adv banner-mpu" adonis-marker data-pan-sizes="[[300,250]]">
<!-- /8095840/.2_A.35452.4_gsmarena.com_tier1 -->
<div id='div-gpt-ad-gsmarenacom35452' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-gsmarenacom35452'); });
</script>
</div>
	</div>







<div class="module module-news-l">
<h4 class="section-heading">Related articles</h4>
<ul>
<li>
	<a href="newsdetail.php3?idNews=45228&c=10001">
		<img src="https://fdn.gsmarena.com/imgroot/news/20/09/s20-fe-tenaa/-184x111/gsmarena_000.jpg" alt="">
		<span>Samsung Galaxy S20 FE 5G passes by TENAA, confirms key specs</span>
	</a>
</li>
<li>
	<a href="newsdetail.php3?idNews=45205&c=10001">
		<img src="https://fdn.gsmarena.com/imgroot/news/20/09/samsung-galaxy-zfold2-design-videos/-184x111/gsmarena_000.jpg" alt="">
		<span>Samsung's designers talk about the innovation of the Galaxy Z Fold2 in a series of videos</span>
	</a>
</li>
<li>
	<a href="newsdetail.php3?idNews=45209&c=10001">
		<img src="https://fdn.gsmarena.com/imgroot/news/20/09/samsung-galaxy-note20ultra-5g-bom/-184x111/gsmarena_000.jpg" alt="">
		<span>Samsung Galaxy Note20 Ultra 5G BoM is $550, analysts estimate</span>
	</a>
</li>
<li>
	<a href="newsdetail.php3?idNews=45212&c=10001">
		<img src="https://fdn.gsmarena.com/imgroot/news/20/09/galaxy-zfold2-thom-browne-sold-out-in-china/-184x111/gsmarena_000.jpg" alt="">
		<span>Samsung Galaxy Z Fold2 Thom Browne edition sells out in China in just 4 minutes</span>
	</a>
</li>
</ul>	
</div>


<div class="adv"><!-- /8095840/.2_A.35282.4_gsmarena.com_tier1 -->
<!-- 300x250mid-left-mpu -->
<div id='div-gpt-ad-300x250mid-left-mpugsmarenadesktop-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-300x250mid-left-mpugsmarenadesktop-0'); });
</script>
</div>
</div>

<div class="module reviews-xl-snazzy">
<h4 class="section-heading">Popular reviews</h4>

<a href="samsung_galaxy_note20_ultra_5g-review-2149.php" class="module-reviews-xl-link">
  <img class="module-reviews-xl-thumb xl-thumb-large" src="https://fdn.gsmarena.com/imgroot/reviews/20/samsung-galaxy-note20-ultra/review18/-347x151/gsmarena_003.jpg" alt="Samsung Galaxy Note20 Ultra 5G review">
  <div class="module-review-xl-title">
    <span></span><br>
    <strong>Samsung Galaxy Note20 Ultra 5G review</strong>
  </div>
</a>
<a href="google_pixel_4a-review-2148.php" class="module-reviews-xl-link">
  <img class="module-reviews-xl-thumb xl-thumb-large" src="https://fdn.gsmarena.com/imgroot/reviews/20/google-pixel-4a/-347x151/HEADER-IMAGE1.jpg" alt="Google Pixel 4a review">
  <div class="module-review-xl-title">
    <span></span><br>
    <strong>Google Pixel 4a review</strong>
  </div>
</a>
<a href="oneplus_nord-review-2146.php" class="module-reviews-xl-link">
  <img class="module-reviews-xl-thumb xl-thumb-large" src="https://fdn.gsmarena.com/imgroot/reviews/20/oneplus-nord/review/-347x151/gsmarena_001.jpg" alt="OnePlus Nord review">
  <div class="module-review-xl-title">
    <span></span><br>
    <strong>OnePlus Nord review</strong>
  </div>
</a>

</div>
 

<div class="adv banner-mpu sticky-mpu">
<!-- /8095840/.2_A.34911.7_gsmarena.com_tier1 -->
<div id='div-gpt-ad-300x600btfgsmarenadesktop-0'  style='height:600px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-300x600btfgsmarenadesktop-0'); });
</script>
</div>
</div>


</aside>

</div><!-- id body -->
</div><!-- id outer -->




<div id="footer">
 <div class="footer-logo">
     <img src="https://fdn2.gsmarena.com/w/css/logo-gsmarena-com.gif" alt="" />
    </div>
    <div id="footmenu">
<p>
<a href="/">Home</a>
<a href="news.php3">News</a>
<a href="reviews.php3">Reviews</a>
<a href="compare.php3">Compare</a>
<a href="network-bands.php3">Coverage</a>
<a href="glossary.php3">Glossary</a>
<a href="faq.php3">FAQ</a>

<a href="rss-news-reviews.php3" class="rss-icon">RSS feed</a></li>
<a target="_blank" rel="noopener" href="https://www.facebook.com/GSMArenacom-189627474421/" class="fb-icon">Facebook</a>
<a target="_blank" rel="noopener" href="https://twitter.com/gsmarena_com" class="tw-icon">Twitter</a>

</p>

<p>
&copy; 2000-2020 <a href="team.php3">GSMArena.com</a> 
<a href="https://www.gsmarena.com/switch.php3?ver=mobile&ref=MGx%2BcmxqcXhAeH5zfmdmQHIsLmwybXppdnpoMi0uKSwxb3dv">Mobile version</a>
<a target="_blank" rel="noopener" href="https://play.google.com/store/apps/details?id=com.gsmarena.android">Android app</a>
<a href="contact.php3">Contact us</a>
<a href="privacy-policy.php3">Privacy</a> 
<a href="terms.php3">Terms of use</a>
<!-- OneTrust Cookies Settings link start -->
<a id="ot-sdk-btn" class="ot-sdk-show-settings" style="padding: 0; border: none">Change Ad Consent</a>
<!-- OneTrust Cookies Settings link end -->
			
</p>			
<div id="cdn-hosting">
<a href="http://www.maxcdn.com/" target="_blank" rel="nofollow noopener">
  <span class="center">CDN by</span><br />
  <img src="https://cdn2.gsmarena.com/w/css/maxcdn.gif" alt="" />
</a>
</div>
  </div>
 </div>
 
 
</div>


<script type="text/javascript" src="https://fdn.gsmarena.com/vv/assets12/js/autocomplete.js"></script>
<script type="text/javascript" language="javascript">
AUTOCOMPLETE_LIST_URL = "/quicksearch-8089.jpg";
$gsm.addEventListener(document, "DOMContentLoaded", function() 
{
    new Autocomplete( "topsearch-text", "topsearch", true );
}
)
</script>


<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	ga('create', 'UA-131096-1', 'auto' );
	ga('set', 'anonymizeIp', true);
	ga('send', 'pageview'
, { 'dimension2': '71' }
	);

</script>






</body></html>
